icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.ayselyucel.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

华彩彩票 www.525.pw-绍兴福彩官网| www.03822.com-网上14彩-| www.64064.com-竞彩不如外围| www.107977.com-彩票在手机上挂| www.194614.com-快开彩票平台| www.284268.com-福利彩票包括哪些| www.414771.com-竞彩m串n组合表| www.532005.com-临沂孙大夫彩票博客| www.644033.com-九州彩票代打| www.751325.com-今日中彩有托吗| www.837381.com-竞彩赚返点的打法| www.912062.com-快三数字分析软件| www.975460.com-黑马团队时时彩| www.yz14.com-福利彩票看哪里中奖| www.42vt.com-任九新浪爱彩| www.959.hk-七乐彩模拟-| www.8417.pw-七星彩结果开出| www.46400.com-南京竞彩快三走势图| www.99947.cc-168彩票怎么样| www.083971.com-彩盈娱乐app下载| www.163550.com-聚彩论坛网-| www.299361.com-彩票怎么看走势| www.383156.com-16号彩票开奖结果| www.531833.com-安卓版彩票33下载| www.631419.com-好彩一八指什么数字| www.715975.com-彩票双色球软件| www.802916.com-长沙中国的彩票| www.886757.com-大大彩票是骗局吗| www.jx5.cc-体育彩票骗局大揭密| www.sh77.cc-五分时时彩开奖信息| www.22nq.com-买彩票网-| www.694.mobi-美人鱼彩票套路| www.5797.biz-体彩小军-| www.19544.com-彩票都没中奖| www.69977.cc-中国体育彩票6等| www.081083.com-728彩票下载安装| www.160922.com-北京福彩联系电话| www.268671.com-鸿彩网平台-| www.365492.cc-彩富天下网址| www.471905.com-够力彩票开奖| www.566062.com-怎样买彩票能中大奖| www.652655.com-体育博彩qq群| www.780227.com-梦图解码七星彩大全| www.866303.com-彩票查询手机彩票网| www.941845.com-快三数学概率题| 百姓彩票www.www.bxcp3333.com| www.gf11.com-2分彩骗局-| www.zm62.com-彩神8网站-| www.35ff.com-体彩刮刮奖中奖技巧| www.1654.top-彩易科思合作app| www.8844.mobi-779彩票网站| www.48511.com-足彩滚球正规app| www.99538.cc-福建体彩十一走势图| www.077499.cc-破解福彩3d妙招| www.152322.com-专业购彩平台tt| www.281986.com-七乐彩专家预测总汇| www.376889.com-开奖结果查询彩宝贝| www.507926.com-中兴彩票平台| www.586834.com-彩吧旧版-| www.693023.com-江苏体彩手机投注| www.785440.com-m5彩票-| www.854414.com-金冠彩票软件下载| www.912783.com-欢乐彩官网-| www.977839.com-500万彩票网上| www.wc31.com-兰州市福彩中心| www.19ac.com-琼海彩票网-| www.254.net-只有3个数的彩票| www.4375.biz-即开型体育彩票| www.01458.com-送彩金棋牌大全网| www.72721.com-吉林快三统计表| www.043418.com-足彩今日欧冠分析| www.131492.com-有快三的中彩彩票网| www.212820.com-五省快三开奖走势图| www.289619.com-国乐彩是正规网站吗| www.402800.com-陕西福彩块三| www.516444.com-中发彩-| www.588342.com-体彩七星彩怎么开奖| www.666371.com-中体彩科技-| www.747351.com-app新浪爱彩| www.821798.com-聚彩彩票官网| www.897655.com-快易彩app下载| www.967609.com-彩票开奖网查询| www.kx74.com-快三36期开奖号码| www.j40.com-今晚福彩开奖吗| www.44pg.com-uc彩票22-| www.619.in-时时彩脱水软件| www.4516.vip-竞彩推荐网易| www.9994.loan-万彩办公大师| www.79630.com-彩吧图迷第一版总汇| www.031417.com-亿发彩票是不是骗局| www.111260.com-河北快三出号统计图| www.184838.com-快3快彩网破解器| www.258060.com-地主彩票-| www.330653.com-上海快三软件真的吗| www.403433.com-海南七星彩官方网站| www.509466.com-澳客赢家彩票ios| www.583159.com-全彩色漫画-| www.656679.com-北京五分彩是什么| www.894331.com-彩46平台下载| www.962894.com-福彩3d彩图库| 福利彩票www.99677k.com| www.hr21.com-好彩网论坛3d图谜| www.zl59.com-分分彩定胆期期必中| www.22ei.com-彩票追号计划软件| www.0088.com-淘彩吧唐龙断组| www.6456.pw-福利彩票表-| www.16305.com-五分时时彩大小走势| www.60104.com-福利彩票20期| www.031258.com-釉下五彩绘画技法| www.107747.com-福彩3d今天出啥号| www.175361.com-安徽快三开奖时间| www.283408.com-体彩6位数-| www.365686.cc-彩票图片模板| www.451916.com-乐彩彩票软件下载| www.539354.com-福彩店会卖假彩票吗| www.647424.com-网易彩票在那下载| www.717792.com-彩铅少女画-| www.791609.com-买竞彩输得家破人亡| www.868420.com-海南至尊七星彩图纸| www.965251.com-辽宁省体育彩票兑奖| 易彩网www.36166j.com| www.dv58.com-网上福彩快三违法吗| www.vt42.com-惠民彩票平台合法吗| www.08su.com-3d福彩图纸-| www.73kl.com-京彩国际下载| www.1000.com-博友彩平台是真是假| www.02867.com-彩网走势图-| www.53772.com-时时彩个人经验| www.97005.com-福彩3d每期计划| www.059562.com-k彩测速线路| www.157720.com-足彩18085开奖| www.237387.com-中国体育彩足彩开票| www.308765.com-澳门彩票投注哪家好| www.373027.com-800彩下载平台| www.557571.com-彩运来官网登入| www.624358.com-彩333官网地| www.689952.com-足彩胜负彩500网| www.763761.com-足彩加苹果版下载| www.883837.com-博瑞彩票网-| www.951502.com-qq彩票正规吗| www.988881.cc-彩51彩票app| www.cp4660.com-彩票开挂软件免费| www.lq22.com-福彩3d中彩网| www.b90.pw-福彩三d和值走试图| www.25fh.com-做梦梦到彩票没中奖| www.850.blue-福彩36-| www.4653.xyz-打彩票是什么意思| www.9561.org-海南私人彩票| www.57117.com-好球彩票app| www.009047.com-体彩任选5中奖规则| www.070826.com-彩票365退钱| www.131252.com-彩礼的历史-| www.199388.com-福彩快三遗漏数据| www.263373.com-吉林快三开奖时间表| www.383780.com-山西福利彩票块3| www.502961.com-福彩3d今天预测号| www.565737.com-正规彩票是哪几种| www.625331.com-体彩有哪些即开彩票| www.691603.com-烟台福利彩票| www.767911.com-旺彩四肖中特图网站| www.948255.com-好彩网免费资料同行| www.983651.com-足球竞彩外围app| www.fy35.com-谁有彩票计划网站| www.vh69.com-福彩十选五是真是假|